Newcomposers.ru

IT Мир
12 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Какая из формул не содержит ошибок

Использование ЕСЛИ с функциями И, ИЛИ и НЕ

Функция ЕСЛИ позволяет выполнять логические сравнения значений и ожидаемых результатов. Она проверяет условие и в зависимости от его истинности возвращает результат.

=ЕСЛИ(это истинно, то сделать это, в противном случае сделать что-то еще)

Но что делать, если необходимо проверить несколько условий, где, допустим, все условия должны иметь значение ИСТИНА или ЛОЖЬ (И), только одно условие должно иметь такое значение (ИЛИ) или вы хотите убедиться, что данные НЕ соответствуют условию? Эти три функции можно использовать самостоятельно, но они намного чаще встречаются в сочетании с функцией ЕСЛИ.

Используйте функцию ЕСЛИ вместе с функциями И, ИЛИ и НЕ, чтобы оценивать несколько условий.

ЕСЛИ(И()): ЕСЛИ(И(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

ЕСЛИ(ИЛИ()): ЕСЛИ(ИЛИ(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

ЕСЛИ(НЕ()): ЕСЛИ(НЕ(лог_выражение1), значение_если_истина; [значение_если_ложь]))

Условие, которое нужно проверить.

Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

Общие сведения об использовании этих функций по отдельности см. в следующих статьях: И, ИЛИ, НЕ. При сочетании с оператором ЕСЛИ они расшифровываются следующим образом:

И: =ЕСЛИ(И(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

ИЛИ: =ЕСЛИ(ИЛИ(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

НЕ: =ЕСЛИ(НЕ(условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

Примеры

Ниже приведены примеры распространенных случаев использования вложенных операторов ЕСЛИ(И()), ЕСЛИ(ИЛИ()) и ЕСЛИ(НЕ()). Функции И и ИЛИ поддерживают до 255 отдельных условий, но рекомендуется использовать только несколько условий, так как формулы с большой степенью вложенности сложно создавать, тестировать и изменять. У функции НЕ может быть только одно условие.

Ниже приведены формулы с расшифровкой их логики.

=ЕСЛИ(И(A2>0;B2 0;B4 50);ИСТИНА;ЛОЖЬ)

Если A6 (25) НЕ больше 50, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае значение не больше чем 50, поэтому формула возвращает значение ИСТИНА.

Если значение A7 («синий») НЕ равно «красный», возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ.

Обратите внимание, что во всех примерах есть закрывающая скобка после условий. Аргументы ИСТИНА и ЛОЖЬ относятся ко внешнему оператору ЕСЛИ. Кроме того, вы можете использовать текстовые или числовые значения вместо значений ИСТИНА и ЛОЖЬ, которые возвращаются в примерах.

Вот несколько примеров использования операторов И, ИЛИ и НЕ для оценки дат.

Ниже приведены формулы с расшифровкой их логики.

Если A2 больше B2, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае 12.03.14 больше чем 01.01.14, поэтому формула возвращает значение ИСТИНА.

=ЕСЛИ(И(A3>B2;A3 B2;A4 B2);ИСТИНА;ЛОЖЬ)

Если A5 не больше B2, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае A5 больше B2, поэтому формула возвращает значение ЛОЖЬ.

Использование операторов И, ИЛИ и НЕ с условным форматированием

Вы также можете использовать операторы И, ИЛИ и НЕ в формулах условного форматирования. При этом вы можете опустить функцию ЕСЛИ.

На вкладке Главная выберите Условное форматирование > Создать правило. Затем выберите параметр Использовать формулу для определения форматируемых ячеек, введите формулу и примените формат.

«Изменить правило» с параметром «Формула»» xmlns_AntiXSS=»urn:AntiXSSExtensions» />

Вот как будут выглядеть формулы для примеров с датами:

Использование ЕСЛИ с функциями И, ИЛИ и НЕ

Функция ЕСЛИ позволяет выполнять логические сравнения значений и ожидаемых результатов. Она проверяет условие и в зависимости от его истинности возвращает результат.

=ЕСЛИ(это истинно, то сделать это, в противном случае сделать что-то еще)

Но что делать, если необходимо проверить несколько условий, где, допустим, все условия должны иметь значение ИСТИНА или ЛОЖЬ (И), только одно условие должно иметь такое значение (ИЛИ) или вы хотите убедиться, что данные НЕ соответствуют условию? Эти три функции можно использовать самостоятельно, но они намного чаще встречаются в сочетании с функцией ЕСЛИ.

Читать еще:  Проверка ошибок в тексте

Используйте функцию ЕСЛИ вместе с функциями И, ИЛИ и НЕ, чтобы оценивать несколько условий.

ЕСЛИ(И()): ЕСЛИ(И(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

ЕСЛИ(ИЛИ()): ЕСЛИ(ИЛИ(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

ЕСЛИ(НЕ()): ЕСЛИ(НЕ(лог_выражение1), значение_если_истина; [значение_если_ложь]))

Условие, которое нужно проверить.

Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

Общие сведения об использовании этих функций по отдельности см. в следующих статьях: И, ИЛИ, НЕ. При сочетании с оператором ЕСЛИ они расшифровываются следующим образом:

И: =ЕСЛИ(И(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

ИЛИ: =ЕСЛИ(ИЛИ(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

НЕ: =ЕСЛИ(НЕ(условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

Примеры

Ниже приведены примеры распространенных случаев использования вложенных операторов ЕСЛИ(И()), ЕСЛИ(ИЛИ()) и ЕСЛИ(НЕ()). Функции И и ИЛИ поддерживают до 255 отдельных условий, но рекомендуется использовать только несколько условий, так как формулы с большой степенью вложенности сложно создавать, тестировать и изменять. У функции НЕ может быть только одно условие.

Ниже приведены формулы с расшифровкой их логики.

=ЕСЛИ(И(A2>0;B2 0;B4 50);ИСТИНА;ЛОЖЬ)

Если A6 (25) НЕ больше 50, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае значение не больше чем 50, поэтому формула возвращает значение ИСТИНА.

Если значение A7 («синий») НЕ равно «красный», возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ.

Обратите внимание, что во всех примерах есть закрывающая скобка после условий. Аргументы ИСТИНА и ЛОЖЬ относятся ко внешнему оператору ЕСЛИ. Кроме того, вы можете использовать текстовые или числовые значения вместо значений ИСТИНА и ЛОЖЬ, которые возвращаются в примерах.

Вот несколько примеров использования операторов И, ИЛИ и НЕ для оценки дат.

Ниже приведены формулы с расшифровкой их логики.

Если A2 больше B2, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае 12.03.14 больше чем 01.01.14, поэтому формула возвращает значение ИСТИНА.

=ЕСЛИ(И(A3>B2;A3 B2;A4 B2);ИСТИНА;ЛОЖЬ)

Если A5 не больше B2, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае A5 больше B2, поэтому формула возвращает значение ЛОЖЬ.

Использование операторов И, ИЛИ и НЕ с условным форматированием

Вы также можете использовать операторы И, ИЛИ и НЕ в формулах условного форматирования. При этом вы можете опустить функцию ЕСЛИ.

На вкладке Главная выберите Условное форматирование > Создать правило. Затем выберите параметр Использовать формулу для определения форматируемых ячеек, введите формулу и примените формат.

«Изменить правило» с параметром «Формула»» xmlns_AntiXSS=»urn:AntiXSSExtensions» />

Вот как будут выглядеть формулы для примеров с датами:

Какая из формул не содержит ошибок:

а) =ЕСЛИ ((С4>4) И (C5>4)); «Принят!»;»Не принят»
б) =ЕСЛИ (И(D2=0;B24);D3-A1;D3+A1)
в) =ЕСЛИ ((A4-0 И D1 10;C2>10);1;»ура!»)

г) =ЕСЛИ (ИЛИ(A2>10;C2>10);1;»ура!») — На мой взгляд

Другие вопросы из категории

страниц . Сколько символов в строке?

Вопросы:
Совокупность всех команд, которые могут быть выполнены некоторым исполнителем. (3 буквы)
Разработчик алгоритмов; управляет работой других исполнителей по исполнению алгоритмов; исполнитель алгоритмов. (7 букв)
Замена части труда человека работой машин (автоматичесикх устройств). (13 букв)

Читайте также

В) компьютер — его процессор;

Г) компьютер — его техническое описание.

2. Информационной моделью, которая имеет иерархическую структуру является .

А) файловая система компьютера;

Б) расписание уроков;

В) таблица Менделеева;

Г) программа телепередач.

3. Какая модель является статической (описывающей состояние объекта)?

А) формула химического соединения;

Б) формулы равноускоренного движения;

В) формула химической реакции;

Г) второй закон Ньютона.

4. Информационной моделью, которая имеет сетевую структуру является .

А) файловая система компьютера;

Б) таблица Менделеева;

Читать еще:  Код ошибки 505 как исправить

В) генеалогическое дерево семьи;

Г) модель компьютерной сети Интернет.

5. Информационной (знаковой) моделью является …

А) анатомический муляж;

В) модель корабля;

Г) химическая формула.

6. В информационных моделях разомкнутых систем управления отсутствует .

А) управляющий объект;

Б) управляемый объект;

В) канал управления;

Г) канал обратной связи.

7. Какие из приведенных ниже определений понятия «модель» верные? Отметить все правильные на ваш взгляд ответы.

А) модель — это некое вспомогательное средство, объект, ко торый в определенной ситуации заменяет другой объект;

Б) модель — это новый объект, который отражает некоторые стороны изучаемого объекта или явления, существенные с точки зрения цели моделирования;

В) модель — это физический или информационный аналог объекта, функционирование которого — по определенным парамет рам — подобно функционированию реального объекта;

Г) модель некоторого объекта — это другой объект (реаль ный, знаковый или воображаемый), отличный от исходного, он обладает существенными для целей моделирования свойствами и в рамках этих целей полностью заменяет исходный объект.

8. Вставьте в предложение наиболее точный термин из предло женного ниже списка.

Если материальная модель объекта — это его физическое подобие, то информационная модель объекта — это его .

Б) точное воспроизведение;

В) схематичное представление;

9. Какое из утверждений верно?

А) информационные модели одного и того же объекта, пусть даже предназначенные для разных целей, должны быть во многом сходны;

Б) информационные модели одного и того же объекта, предназначенные для разных целей, могут быть совершенно разными.

10. Может ли передаваться информация от человека к человеку и от поколения к поколению без использования моделей?

А) нет, без моделей никогда не обойтись;

Б) да, иногда, например, генетическая информация;

В) да, чаще всего знания передаются без использования ка ких-либо моделей.

11. Верно ли, что моделирование представляет собой один из основных методов познания, способ существования знаний?

12. Какие из приведенных ниже моделей являются вероятност ными? Выбрать три правильных ответа.

А) прогноз погоды;

Б) отчет о деятельности предприятия;

В) схема функционирования устройства;

Г) научная гипотеза;

Д) оглавление книги;

Е) план мероприятий, посвященных Дню Победы.

13. Правильно ли определен вид следующей модели: «Компью терная модель полета мяча, брошенного вертикально вверх, — динамическая формализованная модель, имитирующая поведение данного объекта»?

заглядывая в него), чтобы среди вытянутых шаров:. 1)Оказался хотя бы 1 чёрный 2)Оказался хотя бы 1 белый 3)Оказались хотя бы 2 чёрных 4)Окаазались хотя бы 2 белых Если можно с решением,логическим рядом. 2. В одной книге было написано 100 следующих утерждений. «В этой книге роно одно неверное утверждение» «В этой книге ровно два неверных утверждения» . «В этой книге ровно сто неверных утверждений. Какое из этих утерждений верное? Судя по моим мыслям,это явно не 3, тогда это получается правда, что противоречит смыслу предложения. Тогда какое получается? Я не знаю.Помогите пожалуйста. Напишите всё с решением пожалуйста. Ах да,чуть не забыла. Если кто -то знает бесплатный решебник ( без всяких файлообменников) напишите пожалуйста.

и сколько в какой группе должно быть машин. Всего на площадке 5 машин. Сколько возможных разбиений существует? Учтите, что группа может не содержать машин вообще. Кроме того, все машины отличаются друг от друга, а группы неотличимы.

кий диск, флэш-память, колонки.

2. Компьютер Вани имеет следующие характеристики:

тактовая частота – 1,7 ГГц,

— объём оперативной памяти – 256 Мбайт.

Ваня хочет приобрести диски с компьютерными играми, на которых указаны следующие системные требования:

Диск 1. Процессор с тактовой частотой 1,5 Ггц, объём ОП – 256 Мбайт

Диск 2. Процессор с тактовой частотой 2 ГГц, объём ОП – 256 Мбайт

Диск 3. Процессор с тактовой частотой 1,7 Ггц, объём ОП – 512 Мбайт

Читать еще:  Почему показывает ошибку

Диск 4. Процессор с тактовой частотой 1,3 Ггц, объём ОП – 128 Мбайт.

Какие из указанных дисков Ване не стоит приобретать и почему?

3. Какова максимальная разрядность современных процессоров?

4. Расположите устройства внешней памяти в порядке убывания их объёма: CD-ROM, жёсткий диск, дискета, DVD-ROM.

5. В чём преимущества использования флэш-памяти перед другими видами внешней памяти?

Как преобразовалась формула? Если можно,то обьясните пожалуйста как это делать

Тема IV. Технология обработки числовых данных

Тест 4.1. Знакомство с электронными таблицами

1. Электронная таблица – это:

1) приложение, хранящее и обрабатывающее данные в прямоугольных таблицах и предназначенное для автоматизации расчетов

2) программные средства, осуществляющие поиск информации

3) приложение, предназначенное для сбора, хранения, обработки и передачи информации

4) приложение, предназначенное для набора и печати таблиц

2. Независимые поля:

1) содержат исходные данные для расчетов

2) вычисляются через значения других столбцов

Определите, какие столбцы будут вычисляемыми:

1) 5, 6

4) нет вычисляемых столбцов

4. Документ в электронной таблице называется:

1) рабочая книга

5. Рабочая книга состоит из:

1) строк и столбцов

2) рабочих листов

6. В электронной таблице буквами A, B, … обозначаются:

2) столбцы

4) нет таких обозначений

7. В электронной таблице числами 1, 2, … обозначаются:

1) строки

4) нет таких обозначений

8. В электронной таблице А1, В4 – это обозначения:

3) ячеек

4) нет таких обозначений

9. Данные в электронных таблицах – это только:

1) текст, число и формула

2) текст и число

4) число и формула

Тест 4.2. Ввод информации в электронные таблицы

1. Какие данные не могут находиться в ячейке:

2) лист

2. В ячейку введены символы А1+В1. Как Excel воспримет эту информацию?

3) текст

3. В ячейку введены символы =А1+Б1. Как Excel воспримет эту информацию?

1) ошибка

4. В ячейку введены символы =В3*С3. Как Excel воспримет эту информацию?

2) формула

5. Числовая константа 300 000 может быть записана в виде:

4) 3,0Е+5

6. Числовая константа 0,00045 может быть записана в виде:

1) 4,5Е-4

7. Какая формула содержит ошибку?

3) =7A1+1

8. Какая формула содержит ошибку?

1) =2(А1+В1)

9. Дано математическое выражение: . Как запишется эта формула в электронной таблице, если значение x хранится в ячейке А1?

3) =5*А1/(25*(А1+1))

10. Дана формула =В1/С1*С2. Ей соответствует математическое выражение:

1)

2)

3)

4)

Тест 4.3. Фрагменты таблицы. Относительная и абсолютная адресация

1. Адрес какой ячейки является относительным?

D4

2. Адрес какой ячейки является абсолютным?

2) $F$3

3. В каком адресе не может меняться номер строки при копировании?

2) D$9

4. Сколько ячеек содержит выделенная область А2:С4?

4) 9

5. В ячейки D5, D6, E5, E6 введены соответственно числа: 8, 3, 5, 2. В ячейке G3 введена формула =СУММ(D5:E6). Какое число будет в ячейке G3?

4) 18

6. В ячейку Е4 введена формула =$C2+D3. Содержимое Е4 скопировали в ячейку G4. Какая формула будет в G4?

3) =$C2+F3

7. В ячейку D3 введена формула =В1*С2. Содержимое D3 скопировали в ячейку D7. Какая формула будет в D7?

2) =В5*С6

8. В ячейки С4, С5, D4, D5 введены соответственно числа: 5, 3, 4, 8. В ячейке Е9 введена формула =СРЗНАЧ(С4:D5). Какое число будет в ячейке Е9?

2) 5

Опора деревянной одностоечной и способы укрепление угловых опор: Опоры ВЛ — конструкции, предназначен­ные для поддерживания проводов на необходимой высоте над землей, водой.

Поперечные профили набережных и береговой полосы: На городских территориях берегоукрепление проектируют с учетом технических и экономических требований, но особое значение придают эстетическим.

Общие условия выбора системы дренажа: Система дренажа выбирается в зависимости от характера защищаемого.

Ссылка на основную публикацию
Adblock
detector